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HOW TO

add automated functions to Excel

Add Automated

by Kris Fong and Helen Bradley

Functions to Excel
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[SnlaCKAddCt Packing Invoice

WHAT YOU NEED

123 Fruit Loop, New York, NY 10101 = 800.555.1212

* Microsoft Excel

Date: |3/1IO3 I Onler1|10003734X8338$FYG$03HF734BDFG

($399 stand alone or
$499 as part of Office v.X,
www.microsoft.com/mac)

Max

same
150 North Hill Drive
Brisbane, CA 94005

* MacAddict Invoice
Example worksheet or

SR[E S [R[ERE[SE R[50 5[5 5 S ]E]s ] =[] o] & o] =

. . 10098567 |Choco-latte Sour Neon Gummy Worms (8 0z.) 2 $4.50 $9.00
your own invoice 24563698 | Butter-Fried Beef lerky (16 0z.) 4 $12.00 $48.00
37609823 Marshmallow Burgers & Fries (12 0z.) 2 $3.50 $7.00
20912629 | Gourmet Cocktail Wienies w/Kraut (16 0z.) 1 $8.00 $8.00|
Subtotal: $72.00|
) Tax:| n/a
@ textoaydir O 2-30sy O uPps Ground 1| 7.50 | weight (1b.)/Shipping: $52.50|
Payment Type:
] $124.50
THANK YOU!
ON THE
Yy DISC << > i i Sheet1 JSheets JSheets
|Ready Sum=0 [OscrL [Ocars [@num | [ —
Office v. X Test Drive L. .
and MacAddict You can figure out shipping costs the hard way (break out the calculator!) or simply make Excel
Invoice Example crunch the numbers for you.
ven the most dogmatic anti-Microsoft militants agree many may not know that you can use the Forms toolbar
— that that company’s ubiquitous spreadsheet application, to embed custom tools directly into worksheets to automate
| Excel, is a powerful tool when managing business data entries. By using this toolbar, you can create items

activities. After all, how else can you expect to demonstrate your such as buttons and drop-down menus to perform

cost-cutting skills and get that promotion?

one-click entries. Here’s how to add these two functions

While most Excelians know their way around a spreadsheet, to your worksheets.

Create One-Click
Option Entries

fyou’re tired of entering repetitive data into a

spreadsheet, Excel enables you to add option
buttons—what everyone but Microsoft calls radio
buttons—to a worksheet that will automatically fill in
repetitive information. For example, if you’re in retail,
you can add option buttons linked to nonvariable info
such as shipping rates, so that you only have to enter
variable information—such as how many one-pound
bags of Butter-Fried Beef Jerky your customer wants to
buy. Excel then automatically calculates and enters the
shipping rates into a specific cell that you designate in
your invoice.

Sound complicated? It’s not. Here’s how to do it—just

follow along using either our mock shipping invoice (on
the Disc) or a document of your own.
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Add an Option Button open ourinvoice (or your

own) in Excel. From the View menu, select Toolbars > Forms

to display the Forms toolbar. Click the option button tool

(the white circle with a black dot), and then click in the
worksheet to place the button. If you need to move the button,
you can drag it around with your mouse or use the arrow keys to
fine-tune its placement (Shift-Option-click to select a button if it’s
not already highlighted).

THANK YOU!

T sheet1 J'Sheeez J Sheets JT < @ >
sum= Toscu [ocas oMl 11 I

To keep things tidy, we created our first shipping option button
on the same line where our invoice’s shipping cost appears.



Set the Control clicking the button won’t do
you any good unless you assign a function to it. To do
so, Control-click the button and select Format Control
from the contextual menu. In the dialog that appears,
click the Control tab. We want cell E23 to hold the shipping-
code data, so type £23 in the Cell Link field. Then choose
Checked from the Value options, and click OK. With the
button still highlighted, click and drag either of the bounding
box’s right corners until
the button name is fully
size | pr¢ displayed. Then highlight
the default text (option
Value _ button) and type Next Day

Format Control

Colors and Lines

O inchesia Air to replace it.
Checked
" Mixed
Typing E23 in the Cell
Cell link: E23 [2] Linkfield links our option

button to this cell.

Devise a Formula Now that you know your buttons are

working, assign real dollar values for each choice. For example, let’s

say UPS charges $7.00 per pound for Next Day Air delivery, $5.00 per

pound for 2-3 Day shipping, and $1.50 per pound for UPS Ground. In our
invoice, cell F23 contains the package weight in pounds, and cell 123 displays
the total shipping costs. To create a formula that calculates the shipping cost by
weight for all three options and displays the total dollaramount in cell 123, click
cell 123, type =CHOOSE(E23,7,5,1.5)*F23, and press Return. If you have your
own invoice, the formula syntax works like this: =CHOOSE(cell number to which
all buttons are linked, first button’s value,second button’s value,third button’s
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Create More Options Because we also

want options for 2-3 Day and UPS Ground shipping,

we need more buttons. Luckily, all of the buttons you

subsequently create will automatically inherit the same
formatting as the first. Therefore, just select the option button
tool and click in the worksheet next to the first button to create
a second button. Repeat to create a third. With the third button
still highlighted, expand its bounding box to display its default
name, and rename it as UPS Ground. Then Shift-Option-click
the second button to select it, expand its bounding box, and
change its name to 2-3 Day. Test the buttons by clicking each in
turn (clicking one deselects the others); the value shown in cell
E23 (1, 2, or 3, corresponding to the order in which you created
the buttons) should change as you click each button.

I8 it

@ it Day bir (1@ O uPs cround 2 ] weignt (ib.)/

[irrm— Paym|

Rename each option button to reflect your shipping options—this
one will become our 2-3 Day option.

Check It Out 1 test your

formula, suppose you have a

7.5-pound package to ship Next Day

Air. Click the Next Day Air button, type
7.51in cell F23, and press Return. The shipping
cost should show up as $52.50 in cell 123.
Select the 2-3 Day button; the shipping should
come to $37.50. If you select UPS Ground, you
should get $11.25.

Subtotal] $0.00]

value)*cell number that holds the | Tax; n/a
number you’re multiplying by the Subtotal: i 730 We'““tl‘,‘:‘;’r;;mm. $52.50
buttons’ values. __ : $52.50
t (Ib.)/Shipping =CHOOSE(E23,7,5,1.5)*F23 =P TTRETT

. . . Payment Type:
If you use our invoice, type this $U.[l[l|
formula exactly as it appears. THANK YOU! Wanna see the payoff? Just click a shipping

If using your own, apply the
formula to your cells accordingly.

option, enter a weight in cell F23, and fix your
eyeballs on the cell next to Shipping.

Auto-Fill Fields via a
Custom Menu

WHAT YOU NEED

* Microsoft Excel

* MacAddict Invoice Example
worksheet or your own invoice

J ust as you choose items from application and Finder drop-down
menus, you can add menus to your Excel worksheets for quick
access to frequently used information. For example, rather than type

in a customer’s billing- and shipping-address info each time you

ship something to them, you can simply select his or her name from
a drop-down menu list and Excel will enter the shipping info for you.
Here’s how to create a drop-down menu and a formula that extracts

customer info from a customer list.

My First Invoice.xls
E T I H

— c C | e——
SﬁaCkAddl‘C Packing Invoice

123 Fruit Loop, New York,NY 10101 » 800.555.1212

Date: Chong - Order #| 1308948900

fetllze 0sbourne Ship To:
Homer [simesan L Homer Simpson
812 Many Donuts Bty 13Power Plant

i L Springfield XL 0uBi2

DES CRIPTION

QY CE
27457980 Butter-Fried Marshmallow Burgers (2 1b.) 17 $18.00 $306.00]
78445389 Triple-Fried Beef Jerky (16 02.) 4 $12.00 $48.00

Subtotal] $354.00

Tax; n/al

) Mext Day Air () 2-50ay ) ups Ground 1| 3800 | Weight (Ib.)/Shipping:| $266.00|
Payment Type:

TOTAL= $620.00)

THANK YOu!

b sheet1 [Sheetz | sheets JIIT « ()
By creating a menu, all we need to do is choose a customer from
the list to auto-fill the Bill To and Ship To fields.
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Coordinate Two Sheets You need two worksheets of data—one for

your invoice and one for customer info—but you don’t need two separate files; Excel
can stack together related worksheets in a single workbook. Open an invoice in Excel. | _]x sheetl Sh"-Etzk_, sheet3 ..J_
At the bottom of the sheet, there are three numbered tabs that represent separate

worksheets; Sheet 1 is the invoice. To create a customer list, click the Sheet 2 tab. To import Click the Sheet 2 tab to reveal a spankin’-new
contacts from an existing database, skip to step 3. If creating one from scratch, read on. worksheet just waiting for your VIP contacts.

Create a Customer List First
create headers; in cell A1, type Last Name.
Press the Tab key to move to cell B1 and type
First Name. Continue tabbing and typing so

Import Contacts ifyou have contacts in FileMaker or
Entourage, export that data as a tab-delimited text file, open
the file, select all text, copy it, and then paste it into the Excel
worksheet. Delete all columns that don’t contain names or parts

that you have Billing Address in cell C1, City in D1, State of addresses; click the letter at the top of a column to select the entire
in E1, and Zip in F1. Then type in all of your customer column, and then select Delete from the Edit menu. Rearrange columns
contacts starting with cell A2, which should contain the so that they fall in this order, left to right: last name, first name, street
last name of the first person on your list. Don’t worry address, city, state, zip. To move a column, select it, cut it, click the
about alphabetizing for now; we’ll deal with that later. column letter where you want it to appear, and select Cut Cells from the
= D R ———

1 |Last N.:me First N:me Eilling Agdrass City State 0 Zip a Insert menu.

2 Osbourne Qzzy 666 Madrman Wa Beverly Hillz CA 20210 MNickname Company Job Ti

3 Smith Anna Micole 1 Divarce Court  Hollywood CA 90213 Macaddict

- ro Chasch e e Sarz2 eamee kiies ke | We didn’t say importing contacts
6 Chong Tomrmy 4 Grasz Drive Hurnbaoldt CA 93546 Intel .
E Simpson Haormer 512 Many Danuts Sprinaf |’ E:Ej University was gomg to be pretty_you

Once you create column headers, fill in each cell below
them with the appropriate contact info.

Add More, Arrange More Now add four

more columns to hold shipping-address info. Type

Shipping Address in G1, City in H1, State in |1, and

Zip inJ1. Then fill in your customers’ shipping info
accordingly (if billing and shipping are the same, just copy
and paste the info between cells). If you want to change fonts,
formatting, colors, or borders and shading, select Formatting
Palette from the View menu and use its tools to pretty up your
work. To resize a column, drag either of the separator lines
flanking the column’s letter header. To alphabetize by last name,
click and drag down column A from cell A1 to your last entry to
oo select. From the Data menu, select
war nevenns et Sort, In the dialog that appears,

2
inaNicole 1DivorceCourt  Hollywood  CA 9021
DT Ste s ot = s

wm oy = select Column Ain the Sort By pop-

mmy 4 GrassDri

N et mmms @ @sees UP Menu, then click the Ascending
“I radio button next to it. Choose
@ oxan Header Row from the My List Has

= section, and click OK.
7@ D Ascenin

Then by

My list has

©rmen o | Us€ the Sort command to alphabetize
—————— your customers by last name.

Automate the Details 1o have Excel

automatically fill in all billing and shipping info,

create an Index function. To display a first name to

the left of the drop-down menu, click cell B7, type
=INDEX(Customers,A7,2), and press Return. To automate the
billing address, click cell B8 and type =INDEX(Customers,A7,3).
Extract other chunks of data in the same manner—just alter the
last number in the formula to reflect the column number of the
data you want. When you’re done, check your work by selecting
any customer from the menu. Of course, you can also apply what
you just learned to your own worksheet.
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Microsoft
Lucasfilm At Dir|
Pixar

The Cheeseballs

may need to delete a lot of
unnecessary columns.

Create the Menu link your menu, define
your contacts list as customers. Hold down the Shift
key and click the A column header and then the |
column header to select all columns. From the Insert
menu, select Name, and then Define. In the resulting dialog,
type Customers in the box below Names In Workbook and click
OK. Click the Sheet 1 tab to switch to the invoice worksheet,
and from the View menu, select Toolbars > Forms to open the
toolbar. Select the combo box tool and click and drag across cell
D7 to draw a menu. Control-click the menu and select Format
Control from the contextual menu. In the resulting dialog,
type Customers in the Input Range field and type A7 in the Cell

- Link field. Click OK.
SﬁaCkAddl)C Then click any cell to
T Loop, New York, WY TO101 + 8005551212 deselect the menu,

i emersliins: 1 and click the menu to

Bill To: Ship Ta
‘ 45_% select a name.
=
oF

Format Control

s oo f o -0 Usethe combo box tool

wptrange: Cosamers (3] to draw a drop-down
menu on the invoice.

To automate address

Snack Addict | e

123 Fruit Loop, New York, NY 10101 » 800.555.1212
! affected cell.

Bill To: P Kris Fong and
T Helen Bradley
812 Many Donuts E wish for a Word

Springfield | =INDEX(Customers A7,5) Grmeem et ol

. m— automagically generate
ITEM # DES CRIPTION

27457980 ied Marshmallow Burgers ¢; @ Di0 blurb. Oh, wait:
78445389 ed Beef lerky (16 0z.) =RAND().




